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About Visual 
Messaging

Visual Messaging applications allow subscribers to use their desktop 
workstations to access and manage voice messages in various ways. The 
Visual Messaging applications consist of:

● ViewMail®. ViewMail is a family of applications that allows users to 
view and manage voice and e-mail messages on their desktop PC. 
ViewMail can be run as a stand-alone application or integrated with 
one of the following messaging systems:

● ViewMail for Lotus® Notes®. A ViewMail application for Lotus 
Notes users.

● ViewMail for Microsoft® Messaging. A ViewMail application for 
Microsoft messaging (Outlook) application users.

● ViewMail for GroupWise®.  A ViewMail application for GroupWise 
users.

● ViewCall® Plus (with PhoneBASIC®). ViewCall Plus allows users 
to view and manage their incoming calls from their desktop PC.

● ViewFax®. ViewFax allows users to view and manage faxes in their 
fax mailbox and to send faxes directly to a fax machine from their 
desktop PC.

Software required to support Visual Messaging is installed on the unified 
messaging server during the unified messaging installation process. 
However, you will need to install the required Visual Messaging 
applications on each user’s workstation. This guide describes the 
requirements and steps to set up Visual Messaging applications.
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Visual Messaging requirements
The requirements to install and run Visual Messaging applications are 
summarized in the following table. Ensure that all these requirements are 
met before installing.

Component Requirement

Unified messaging system A voice mailbox set up for each subscriber 
as described in the System Management 
Help

LAN Ethernet LAN

Workstation hardware and 
memory

Must meet the requirements of the 
workstation operating system.

Workstation hard disk 
space

For all Visual Messaging applications:

40 MB free hard disk space

Workstation operating 
system

One of the following:

● Windows 2000
● Windows XP
● Windows Vista

Workstation LAN software Appropriate network software and drivers 
installed and set up

Messaging client for 
ViewMail for Lotus Notes

Lotus Notes 5, 6, 6.5, or 7.0

Messaging client for 
ViewMail for Microsoft 
Messaging

Microsoft Outlook XP (Corporate or 
Workgroup version), 2003, or 2007

Messaging client for 
ViewMail for GroupWise

GroupWise 6.0, 6.5, and 7.0

ViewFax ActiveFax package installed on the unified 
messaging system
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Visual 
Messaging 
installation 
overview

The steps to install the Visual Messaging applications are:

1 Install the Visual Messaging software on the 
messaging computer.
If you purchased Visual Messaging as part of a new unified 
messaging system, the software is already installed. Continue with 
the next step.

2 Connect the unified messaging server to the LAN.
A LAN connection is required for Visual Messaging applications. See 
“Connecting the messaging server to the LAN” on page 5.

3 Set up TCP/IP on the workstations.
The TCP/IP network protocol must be set up on each workstation. 
See “Setting up TCP/IP” on page 8.

4 Test the TCP/IP setup.
After you have set it up, test the TCP/IP setup on each workstation. 
See “Testing the TCP/IP setup” on page 11.

5 Install Visual Messaging on the workstations.
You can install the Visual Messaging applications either from the 
Visual Messaging Application Resource disc, or from a network 
location. See “Installing the Visual Messaging applications” on 
page 14.

WANs and the Internet
In addition to running Visual Messaging applications over a LAN, they 
can also run remotely over wide area networks (WANs) and the Internet. 
For details, see “Using Visual Messaging with WANs and the Internet” on 
page 42.

NOTE

After installing Visual Messaging, you need to tell your 
subscribers how to get started using the Visual Messaging 
applications.
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Connecting the 
messaging 
server to 
the LAN

The Visual Messaging applications require the messaging server to be 
connected to the LAN. If you have not already set up a LAN connection 
while installing the messaging server, use the following procedures to test 
the LAN connection and connect the system. If necessary, consult your 
network administrator for assistance in testing the LAN connection.

If you use a firewall, configure it for Visual Messaging access after you 
have connected the messaging server to the LAN. See “Setting up Visual 
Messaging firewall access” on page 6.

To test the LAN connection

1 Use a network analyzer or a workstation that works correctly with the 
network. Connect it to the LAN, using the same network cable that 
the messaging server will use.

2 Verify that the network analyzer or workstation can communicate 
with the network.

If the unit cannot communicate correctly with the network, there is a 
problem with the network cable or connection. Consult with your 
network administrator for assistance in resolving the problem.

3 Following a successful test, disconnect the network cable from the 
network analyzer or workstation.

To connect the messaging server to the LAN

❚ Plug the network cable into the Ethernet connector on the 
messaging server.
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Setting up Visual Messaging firewall access
The firewall on the messaging server is turned off by default. If you turn 
on the firewall, it must be set up to allow Visual Messaging TCP port 
access. Otherwise, the Visual Messaging applications will not work 
properly.

If the firewall is currently turned off, then you do not need to do this 
procedure.

To configure the messaging server firewall for 
Visual Messaging access

1 Log on to the messaging server as the administrator.

2 From the taskbar, click Start > Settings > Control Panel.

3 On the Control Panel, double-click Windows Firewall.

4 Click the Exceptions tab.

5 Click Add Port. 

The Add a Port dialog box appears.

6 In the Name field, type  Visual Messaging.

7 In the Port number field, type 1024.

8 Confirm that TCP is selected, then click OK.

9 Click OK to close the Windows Firewall dialog box.
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Joining a domain
You might already have joined a domain during the initial messaging 
server setup. If you did not join a domain at that time and wish to do so 
now, use the following procedure.

To join a domain

1 On the Windows desktop, right-click the My Computer icon then 
click Properties.

2 Click the Computer Name tab.

3 Click Change to join a domain.

4 Select either Domain or Workgroup as appropriate, and type the 
name of the domain or workgroup you want to join. 

If unsure of which selection to make, consult your network 
administrator.

5 Click OK.

6 Click OK to close the System Properties dialog box.
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Setting up 
TCP/IP

The Visual Messaging applications use TCP/IP as the communications 
protocol. TCP/IP must be set up on each workstation that is using Visual 
Messaging applications.

The steps to set up TCP/IP vary for different versions of Windows. The 
Visual Messaging applications are supported on the following Windows 
versions:

● Windows 2000

● Windows XP

● Windows Vista (32 bit)

The following sections describe how to set up TCP/IP for each supported 
version of Windows. Refer to the appropriate section for each type of 
workstation.

● To set up TCP/IP for  Windows 2000, see “Setting up TCP/IP for 
Windows 2000” below.

● To set up TCP/IP for Windows XP or Windows Vista (32 bit), see 
“Setting up TCP/IP for Windows XP or Windows Vista (32 bit)” on 
page 10.

Setting up TCP/IP for Windows 2000
Use the following procedure to set up TCP/IP on Windows 2000 
workstations.

To set up TCP/IP on a Windows 2000 workstation

1 From the taskbar, click Start > Settings > Control Panel.

2 On the Control Panel, double-click Network and Dial-up 
Connections.

NOTE

The Visual Messaging applications do not support 
Windows 95, 98 or NT

NOTE

You must be a Windows 2000 administrator or a member 
of the power user group to do this procedure. If you 
attempt to do the procedure without administrative rights, 
an error message will appear, indicating that you have 
insufficient rights to change the settings.
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3 In the Network and Dial-up Connections dialog box, right-click 
Local Area Connection, then click Properties.

4 On the Local Area Connection Properties dialog box, click the 
General tab.

5 Review the list of components to determine whether or not Internet 
Protocol (TCP/IP) is listed. Do one of the following:

■ If TCP/IP is listed, then it is already installed. Click Cancel, and 
skip to step 10.

■ If TCP/IP is not listed, then you must install it. Continue with 
the next step.

6 Click Install. 

The Select Network Component Type dialog box appears.

7 From the list of network components, click Protocol, then click 
Add.

8 On the Select Network Protocol dialog box, select Internet 
Protocol (TCP/IP) then click OK.

TCP/IP is installed; this might take a few moments.

9 Click Close to close the Local Area Connection Properties dialog 
box.

10 Close the Network and Dial-up Connections dialog box.

11 Test the TCP/IP setup. See “Testing the TCP/IP setup” on page 11.
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Setting up TCP/IP for Windows XP or Windows 
Vista (32 bit)
Use the following procedure to set up TCP/IP on Windows XP or 
Windows Vista (32 bit) workstations.

To set up TCP/IP on a Windows XP or Windows 
Vista (32 bit) workstation

1 From the  taskbar, click Start > Control Panel.

2 On the Control Panel, click Network and Internet Connections.

3 Click Network Connections.

4 Right-click Local Area Connection, then click Properties.

5 On the Local Area Connections Properties dialog box, click Install.

6 Click Protocol, then click Add.

7 Click TCP/IP, then click Add.

8 Test the TCP/IP setup. See “Testing the TCP/IP setup” on page 11.

NOTE

You must be a Windows XP or Windows Vista administrator 
or a member of the power user group to do this procedure. 
If you attempt to do the procedure without administrative 
rights, an error message will appear, indicating that you 
have insufficient rights to change the settings.
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Testing the 
TCP/IP setup

After setting up TCP/IP on each workstation, verify that the workstation 
can communicate with the messaging server by doing the following 
procedures in order.

Testing the TCP/IP setup with Ping
The following procedure uses the Microsoft Ping utility to test basic 
network connectivity between the workstation and the messaging server.

To test the TCP/IP setup with Ping

1 On the workstation, open a command prompt.

2 Type the following:

ping <messaging server> 

where <messaging server> is the name of the messaging server, 
as specified during the initial setup.

Alternately, type 

ping <messaging server IP address> 

where <messaging server IP address> is the IP address of the 
messaging server.

3 Press Enter.

Results of the Ping test
If a Ping reply message appears, indicating a reply from the unified 
messaging system and the correct number of packets received, then the 
TCP/IP protocol is set up properly. Follow the steps in the procedure 
“Testing the TCP/IP setup with Telnet” on page 12.

If any other type of message appears, the TCP/IP protocol is not set up 
properly, or there is another networking problem. Possible causes 
include:

● The network cable is not attached correctly or securely. Confirm that 
the network cable is correctly attached to the workstation.

● TCP/IP is not set up correctly. Repeat the TCP/IP setup procedure.

● The workstation might need to be restarted. Close all files, shut down 
all applications and restart the computer.

● There is a problem with the network. Contact your network 
administrator for assistance.
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Testing the TCP/IP setup with Telnet
If the Ping test is successful, use the following procedure to confirm that 
the Visual Messaging applications can communicate with the unified 
messaging software.

To test the TCP/IP setup with Telnet

1 On the workstation, open a command prompt.

2 Type the following:

telnet <messaging server> 1024 

where <messaging server> is the name of the messaging server, 
as specified during the initial setup.

Alternately, type 

telnet <messaging server IP address> 1024 

where <messaging server IP address> is the IP address of the 
unified messaging server.

3 Press Enter.

4 To exit,

a Press CTRL-]. 

b Type  quit.

c Press ENTER.

Results of the Telnet test
If no text appears and the screen is blank, then a TCP session was 
successfully established and Visual Messaging applications on the 
workstation will be able to communicate with the unified messaging 
system. See “Installing the Visual Messaging applications” on page 14.

If the message  Could not open connection to the host, on port 
1024: Connect failed appears, then the TCP/IP protocol is not set up 
properly, or there is another networking problem. Possible causes 
include:

● TCP/IP is not set up correctly. Repeat the TCP/IP setup procedure.

● A firewall is blocking incoming TCP connections on port 1024. 
Enable connections for port 1024 on the firewall, or contact your 
network administrator for assistance. See “Setting up Visual 
Messaging firewall access” on page 6 for the steps to configure the 
firewall.
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● There is a problem with the network. Contact your network 
administrator for assistance.
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Installing the 
Visual 
Messaging 
applications

You can install the Visual Messaging applications in one of two ways: 
either directly from the Visual Messaging Application Resource disc or 
from a network location.

● To install from the disc,  see “Installing Visual Messaging from the 
disc” on page 16. This method requires that you use the disc to install 
the applications on each workstation.

● To install from a network location,  copy the applications to a 
network location and install them from the network. See “Installing 
Visual Messaging from the network” on page 18.

To install the Visual Messaging applications, you must log on to users’ 
workstations with administrative rights. However, users do not need 
administrative rights to use the Visual Messaging applications after the 
software is installed.

Visual Messaging Application Resource disc
All Visual Messaging applications are provided on the Visual Messaging 
Application Resource disc. This disc supports Visual Messaging on several 
products and platforms.

Each Visual Messaging application is located in a different folder on this 
disc, shown in the table on page 15. When installing the applications, 
specify the correct folder for each application described in the following 
sections. When installing ViewMail, ViewMail for Microsoft Messaging, 
ViewMail for Lotus Notes, ViewMail for GroupWise, ViewCall Plus, or 
ViewFax, install the software from the correct folder on the Visual 
Messaging Application Resource disc. 

For example, to install ViewMail on a workstation at a site where the 
unified messaging system is installed on a Windows server, go to the 
folder named VM\For_Windows_Servers on the Visual Messaging 
Application Resource disc. Double-click the executable file (.EXE file). Or 
to install ViewMail on a workstation at a site where the unified messaging 
system is installed on a Linux server, go to the folder named 
VM\For_Linux_Servers on the Visual Messaging Application Resource 
disc. Double-click the executable file (.exe file).

Make sure you install the Visual Messaging software that matches the 
operating system for the messaging server, not the workstation 

NOTE

If you are installing ViewMail for Lotus Notes, ensure that 
the Domino server is configured correctly before installing 
the application. See “Configuring the Domino server” on 
page 24 for details.
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computer. Refer to the table to determine the correct folder locations on 
the Visual Messaging Application Resource disc.

Table 1: Visual Messaging application folder locations

Visual Messaging applications Messaging server folders

ViewCall Plus VCP\For_Windows_Servers

VCP\For_Linux_Servers

ViewFax VF\For_Windows_Servers

VF\For_Linux_Servers

ViewMail VM\For_Windows_Servers

VM\For_Linux_Servers

ViewMail for Lotus Notes VML\For_Windows_Servers

VML\For_Linux_Servers

ViewMail for Microsoft Messaging VMM\For_Windows_Servers

VMM\For_Linux_Servers

ViewMail for GroupWise VMG\For_Windows_Servers

VMG\For_Linux_Servers

WARNING!

Visual Messaging client applications must not be installed 
on the messaging server. The Visual Messaging client 
applications are intended exclusively for installation and 
use on users’ workstations, not on the messaging server 
itself. If you install any of the Visual Messaging 
applications on the messaging server, this can damage 
your server installation including causing irreparable 
corruption of the system database.
 Installing the Visual Messaging applications 15



Installing Visual Messaging from the disc
Use the following procedure to install Visual Messaging applications 
from the Visual Messaging Application Resource disc.     

To install Visual Messaging applications from the 
disc

1 At the workstation, close all open programs.

2 Insert the Visual Messaging Application Resource disc into the disc 
drive.

3 From the  taskbar, click Start > Run.

 The Run dialog box appears.

4 In the Open field type: 

<drive>:\<folder>\<server type>\<filename>

where:

<drive> is the CD-ROM drive letter,

<folder> is the folder for the required Visual Messaging 
application from the table on page 15,

<server type> is the folder for the messaging server from the table 
on page 15, and

<filename> is the executable (.exe) file located in the folder.

Alternatively, you can click Browse, then browse to the location of 
the required file.

5 Click OK. 

The Visual Messaging application installation wizard starts.

IMPORTANT

Visual Messaging client applications must not be installed 
on messaging servers. The Visual Messaging client 
applications are intended exclusively for installation and 
use on users’ workstations, not on the messaging server 
itself. If you install any of the Visual Messaging 
applications on the messaging server, this can damage 
your server installation including causing irreparable 
corruption of the system database.  
 
Installing ViewMail for Microsoft Messaging is a separate 
installation process. See “Installing ViewMail for Microsoft 
Messaging” on page 34 for the steps.
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6 On the Welcome page, click Next to begin the installation.

7 On the Destination Folder page, specify the folder where the 
application will be installed, then click Next.

You should accept the default destination folder, but you can also 
click Browse to specify a different folder.

8 On the Ready to Install the Application page, click Next. 

The wizard installs the application.

9 You might be prompted to provide additional application-specific 
information. If so, follow the on-screen prompts to provide the 
required information.

10 When the installation is complete, the wizard displays a page 
announcing that the application is successfully installed. Click 
Finish to quit the wizard.

11 You might be prompted to restart the system. If prompted, click Yes 
to restart the computer.

NOTE

If you are installing ViewMail for Lotus Notes, see 
“Configuring ViewMail for Lotus Notes” on page 27 for the 
steps to configure the workstation.
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Installing Visual Messaging from the network
Use the following procedures to install Visual Messaging applications 
from a network location.

To copy the Visual Messaging applications to a 
network location

1 Log on to the network.

2 On a network drive accessible to all workstations, create a new 
installation folder for the Visual Messaging applications. Use either a 
command prompt window or Windows Explorer to create the new 
folder.

For example, to use a command prompt to create a folder named 
Temp on network drive X:, type the following, then press ENTER.

md x:\Temp

3 Insert the Visual Messaging Application Resource disc into the disc 
drive.

4 For each Visual Messaging application you will be installing, copy 
the appropriate folder in the table on page 15 from the disc to the 
network folder created in step 2.

IMPORTANT

Installing ViewMail for Microsoft Messaging is a 
separate installation process. See “Installing ViewMail 
for Microsoft Messaging” on page 34 for the steps.

NOTE

You must have network rights to create folders, copy 
files and grant directory rights to other workstations.
Visual Messaging Installation Guide18



To install Visual Messaging applications from the 
network

1 At the workstation, all open programs.

2 From the  taskbar, click Start > Run. 

The Run dialog box appears.

3 In the Open field type the following:

<path><folder>\<server type>\<filename>

where:

<path> is the path to the network installation folder,

<folder> is the folder for the required Visual Messaging 
application from the table on page 15,

<server type> is the folder for the messaging server from the 
table on page 15, and

<filename> is the executable (.exe) file located in the folder.

Alternatively you can click Browse, and browse to the location of 
the required file.

4 Click OK. 

The installation wizard for the selected Visual Messaging application 
starts.

5 On the Welcome screen, click Next to begin the installation.

6 On the Destination Folder page, specify the folder where the 
application will be installed, then click Next.

 You can either accept the default destination folder or click Browse 
to specify a different folder.

7 On the Ready to Install the Application page, click Next. 

The wizard installs the application.

8 You might be prompted to provide additional application-specific 
information. If so, follow the on-screen prompts.

9 When the installation is complete, the wizard displays a page 
indicating that the application is successfully installed. Click Finish 
to quit the wizard.
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10 You might be prompted to restart the system. If prompted, click Yes 
to restart the computer.

NOTE

If you are installing ViewMail for Lotus Notes, see 
“Configuring ViewMail for Lotus Notes” on page 27 to 
configure the workstation.
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Installing or 
upgrading 
ViewMail

Installing stand-alone ViewMail is a separate installation process that 
does not use the Visual Messaging Application Resource disc. See “Visual 
Messaging application folder locations” on page 15  that describes the file 
locations for your installation.

To install ViewMail on a workstation

1 Verify that you are logged on as a system administrator. If not, log off 
the workstation and log on as a system administrator.

2 Copy the new ViewMail file, VM_3.4.6.8.exe, to a local drive or the 
workstation desktop.

3 Close all open programs.

4 Double-click the VM_3.4.6.8.exe file. The ViewMail installation 
wizard starts. 

5 Follow the on-screen prompts to complete the installation.

6 When the installation is complete, restart the workstation.

7 If the workstation uses the Microsoft Vista operating system, you 
must install WinHlp32.exe to view the help content. 

The WinHlp32.exe file for Vista can be found on the Microsoft web 
site at:  
http://go.microsoft.com/fwlink/?LinkID=82148 

To upgrade from ViewMail 3.3.x.x or later

1 Verify that you are logged on as a system administrator. If not, log off 
the workstation and log on as a system administrator.

2 Copy the new ViewMail file, VM_3.4.6.8.exe, to a local drive or the 
workstation desktop.

3 Close all open programs.

4 Double-click the VM_3.4.6.8.exe file. The ViewMail installation 
wizard starts. 

5 Follow the on-screen prompts to complete the upgrade.

6 When the installation is complete, restart the workstation.

NOTE

This procedure assumes that ViewMail has never been installed 
on the workstation.
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To upgrade from ViewMail 3.2.xx or earlier

1 Verify that you are logged on as a system administrator. If not, log off 
the workstation and log on as a system administrator.

2 Close all open programs.

3 Use the steps below to uninstall ViewMail:

a Click Start > Settings > Control Panel.

b Double-click Add/Remove Programs.

c Select ViewMail from the list and click Remove.

d Follow the on-screen instructions to complete the uninstall 
process.

4 Copy the new ViewMail file, VM_3.4.6.8.exe, to a local drive or the 
workstation desktop.

5 Close all open programs.

6 Double-click the VM_3.4.6.8.exe file. The ViewMail installation 
wizard starts. 

7 Follow the on-screen prompts to complete the upgrade.

8 When the installation is complete, restart the workstation.
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Setting up 
ViewMail for 
Lotus Notes

If you are installing ViewMail for Lotus Notes, additional configuration 
steps are required. These configuration steps are:

1 Configure the Domino server.
Before installing ViewMail for Lotus Notes on the workstations, you 
must first configure the Domino server. See “Configuring the 
Domino server” on page 24.

2 Install ViewMail for Lotus Notes.
Install ViewMail for Lotus Notes on the workstations. See “Installing 
the Visual Messaging applications” on page 14.

3 Configure ViewMail for Lotus Notes.
See “Configuring ViewMail for Lotus Notes” on page 27.

■ If you want to uninstall ViewMail for Lotus Notes, see “To 
uninstall ViewMail for Lotus Notes” on page 46.

■ ViewMail for Lotus Notes does not currently support Lotus 
iNotes or Lotus iNotes templates. See “Using iNotes and 
ViewMail for Lotus Notes” on page 30.
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Configuring the Domino server
Before installing ViewMail for Lotus Notes on the workstations, you must 
first set up the Domino server. This consists of the following steps:

● Make a copy of the database template on the Domino server. See “To 
copy the database template on the Domino server” below.

● Sign the database template and copy the access control list (ACL) 
from the standard mail template. See “To sign the database template 
and copying the access control list (ACL)” on page 25.

● Set up the administration execution control list (ECL).See “Setting 
up the administration execution control list (ECL)” on page 25.

Do the following three procedures in the order presented.

To copy the database template on the Domino 
server

1 On the Domino server, insert the Visual Messaging Application 
Resource disc into the disc drive.

2 Browse to the VML\Domino_Templates folder on the disc, then 
double-click the executable (.exe) file.

3 Type a destination folder on the hard disk, then click Unzip.

4 Click OK and then click Close.

5 Start the Domino Designer utility.

6 Click File > Database > Open.

7 Click Browse.

8 Select the vmlmailxx.ntf file that matches the Domino version 
running on the server. 

For example, if Domino 7.0 is running on the server, select 
vmlMail70.ntf.

9 Click Select, then click Open.

10 Make a copy of the template:

a Click File > Database > New Copy.

b In the Copy Database window, in the Server box, select the 
Domino server name.

c Select the Database design only check box.

d Clear the Access Control List check box.

e Click OK.
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11 Quit the Domino Designer utility.

Next use the following procedure to sign the database template and copy 
the access control list (ACL) to use the new template. 

To sign the database template and copying the 
access control list (ACL)

1 On the Domino server, start the Domino Administrator utility.

2 Click the Files tab.

3 In the Show me box, select Templates only.

4 Select the VML Mail (Rxx) file that matches the Domino version 
number, then click Sign.

For example, if Domino 7.0 is running on the server, select VML 
Mail (R7)

5 In the Sign Database window, select Active User’s ID or Active 
Server’s ID, then click OK.

6 Right-click the VML Mail (Rxx) file that matches the Domino version 
number you are running, then click Access Control > Copy.

For example,  if Domino 7.0 is running on the server, right-click VML 
Mail (R7)

7 Right-click the VML Mail (Rxx) file that matches the Domino version 
number you are running, then click Access Control > Paste.

For example,  if Domino 7.0 is running on the server, right-click VML 
Mail (R7)

Setting up the administration execution control list 
(ECL)

1 On the Domino server, start the Domino Administrator utility.

2 Click the People & Groups tab.

3 Click Action > Edit Administration ECL.

4 In the When signed by list, select the user or server used to sign 
the VML database template.

If the user or server is not displayed, click Add, click the person icon, 
select the user or server, then click OK.

5 In the Workstation Security window, under Allow, select all check 
boxes.
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6 Click OK.

Next step...

◆ Install ViewMail for Lotus Notes on the workstations. 
See “Installing the Visual Messaging applications” on page 14.
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Configuring ViewMail for Lotus Notes
After installing ViewMail for Lotus Notes on the workstation, use the 
following procedures to configure ViewMail for Lotus Notes.

To modify the execution control list for Lotus Notes 
5.0

1 Log on to Lotus Notes.

2 Click File > Preferences > User preferences.

3 Click Security options, then click Refresh.

4 If the user or server used to sign the new e-mail database template 
does not appear in the When code is signed by list, click Add to 
add the user or server.

5 Select the user or server, then click OK. 

6 Under Allow, select all check boxes. 

7 Click OK.

To modify the execution control list for Lotus Notes 
6.0 or 6.5

1 Log on to Lotus Notes.

2 Click File > Security > User security.

3 Type a password.

4 Select What others do, then click Refresh all.

5 If the user or server used to sign the new e-mail database template 
does not appear in the When code is signed by list, click Add to 
add the user or server.

6 Select the user or server, then click OK.

7 Under Allow, select all check boxes. 

8 Click OK.

To modify the execution control list for Lotus Notes 
7.0

1 Log on to Lotus Notes.

2 Click File > Security > User security.

3 Click What others do, then select Using Workstation.
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4 Click Effective Session ECL.

5 If the user or server used to sign the new e-mail database template 
does not appear in the When code is signed by list, click Add to 
add the user or server.

6 Select the user or server, then click OK.

7 Under Allow, select all check boxes.

8 Click OK.

Next, update the database design from the new e-mail template. See “To 
update the database design from the new e-mail template” on page 29.
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To update the database design from the new e-mail 
template

If you will be using the iNotes functionality,  skip this step and go to 
“Using iNotes and ViewMail for Lotus Notes” .

1 Log on to Lotus Notes.

2 Click the Mail icon.

3 From the File menu, click Database > Properties.

4 On the Design tab, select the Inherit design from master 
template check box. 

5 Change the template name to one of the following:

■ VML Mail (R5.0)

■ VML Mail (R6)

■ VML Mail (R65)

■ VML Mail (R7).

6 Click File > Database > Refresh Design to update the e-mail 
database.

7 On the Refresh Database Design screen, select the server that the 
new e-mail database template was installed on, then click OK.

8 Click Yes to confirm.
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Using iNotes and ViewMail for Lotus Notes
The new ViewMail for Lotus Notes iNotes template enables users to work 
with VML on systems that have the Lotus Notes client installed and use 
iNotes on the Web at the same time. 

Changes to the ViewMail for Lotus Notes install 
process when using iNotes 
Use the nConvert utility must be used to convert a users mail file for 
iNotes templates. Users who use iNotes and VML should not use the 
Lotus Notes Client option to replace their databases with the VML 
template.

The Domino administrator must use the nConvert utility with the 
integrated VML/iNotes template.

Using the VMLiNotesxx.ntf Template
To successfully use iNotes and VML, the following templates are 
provided:

● VMLiNotesxx.ntf template

● VMLMailxx.ntf template

■ xx corresponds to the Lotus Notes release/version number.  For 
example the VMLiNotes65.ntf template is for use with Lotus 6.5.

■ To update a user to the VMLiNotesxx.ntf template, 
administrators must ensure the user has VML installed on their 
Lotus Notes Client system.

■ The standard VML template (VMLMailxx.ntf) must be in the 
server data directory. Update the user template using the 
nConvert utility with the VMLiNotesxx.ntf template.

If a user has Lotus Notes Client 6.5 installed, and  is connected to a 
Domino 6.5 server, see the procedure “To update the user’s template” on 
page 31.
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To update the user’s template

1 Install VML 3.4.6.8 or later on the user's PC.

2 Copy the VMLiNotes65.ntf and VMLMail65.ntf templates to the data 
directory on the server.

3 Use the nConvert command to update the user's template:

nconvert mail\theUsersMailFile.nsf  *  
VMLiNotes65.ntf 

Users might have changed the iNotes template that came with the 
Domino Server software.  Customized user templates can inherit the 
VML template without removing the user’s customizations. Follow the 
procedure below to update the iNotes template.

To update the iNotes template

1 Open the iNotes template in Domino Designer. 

2 Click File > Database > Properties.

3 Click the Design icon.

4 Under the Inheritance heading, change Template Name from 
StdRxxMail to VML Mail (Rxx).

5 Under Database file is a master template, change Template name 
from  iNotesxx to iNotesVMLxx.

NOTE

See the IBM Domino documentation for more 
information about the nConvert command.

NOTE

Make sure VMLMailxx.nft is in the same directory as the 
iNotes template.

NOTE

The xx in the template name represents the iNotes 
version number.  For example, the VML template for 
iNotes 6.5 is VMLiNotes65.ntf, and the VML template 
for Lotus Notes Client is VMLMail65.ntf
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6 Click File > Database > Refresh Design.

The iNotes template inherits the VML template without removing 
the user’s customizations.

NOTE

The VMLMailxx.ntf must be in the same directory as 
the iNotes template.
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Installing 
ViewMail for 
Microsoft 
Messaging

ViewMail for Microsoft Messaging can be installed seperately without 
using the Visual Messaging Application Resource disc. This process 
requires that a .exe file is copied over from a network share to each user’s 
workstation. The .exe is then run from each workstation. See “Installation 
file names” on page 34  that describes the manufacturer-specific .exe file 
for your installation.

1 Configure Outlook on each workstation.
Before installing ViewMail for Microsoft Messaging on a workstation:

■ Outlook must be installed as the default mail client and set to 
Corporate/Workgroup mode. See the Outlook documentation 
for instructions.

■ There must also be an Outlook profile for each subscriber using 
ViewMail for Microsoft Messaging on the workstation. See the 
Outlook documentation for instructions.

2 Install ViewMail for Microsoft Messaging.
Install ViewMail for Microsoft Messaging on each workstation. See 
“Installing ViewMail for Microsoft Messaging” on page 34.

3 Configure ViewMail for Microsoft Messaging.
Outlook must be configured for ViewMail for Microsoft Messaging 
on each workstation. Configuration is dependent upon the installed 
version of Outlook and the version of the Windows operating system.  
See “Configuring ViewMail for Microsoft Messaging” on page 36.

NOTE

If you want to upgrade ViewMail for Microsoft 
Messaging from a previous version, see “Upgrading 
ViewMail for Microsoft Messaging” on page 40.
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Installing ViewMail for Microsoft Messaging
The following file must be located on a network share accessible by any 
user wanting to install ViewMail for Microsoft Messaging:

Table 2: Installation file names 

 

The following procedure should be performed on each user’s 
workstation.

To install ViewMail for Microsoft Messaging 

1 Log on to the workstation as a system administrator.

2 Copy the VMM_3.4.6.9.exe file to a local drive or the workstation 
desktop.

3 Close all open applications.

4 Double-click the exe file.

5 On the Welcome page, click Next. 

6 On the Destination page, accept the default installation folder, or 
click Browse, and select a new location. Click Next.

7 On the Installation Type page, choose Typical, then click Next.

8 On the Ready to Install page, click Next.

ViewMail begins to update the system. This might take several 
minutes.

Manufacturer EXE file

Active Voice AV_VMM_3.4.6.9.exe

NEC NEC_VMM_3.4.6.9.exe

EliteMail EM_VMM_3.4.6.9.exe

Tadiran MC_VMM_3.4.6.9.exe

Phillips PH_VMM_3.4.6.9.exe

NOTE

This procedure assumes that ViewMail for Microsoft Messaging 
has never been installed on the workstation. See “To upgrade 
from an earlier version of ViewMail for Microsoft Messaging” on 
page 40 if an older version is already installed.
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9 On the Outlook setup dialog box, type the name or IP address of the 
unified messaging in the Server name field. If the workstation uses 
Outlook 2003 or earlier, select the default protocol. The default 
protocol is typically the TCP/IP. Click Next.

10 On the second Outlook Setup dialog box, type your Personal ID 
and Security Code. These should be provided to you by the system 
administrator. Click Next.

Optionally, select or clear the Automatically enter security 
code when starting check box. If you clear the check box, each 
time you log on to the unified messaging server you will be 
prompted for your security code. 

11 When prompted to delete the EXTEND.DAT file, click Yes.

12 On the confirmation dialog box, click OK.

13 On the installation complete page, click Finish.

14 When prompted to restart the computer, click Yes.

15 Configure the Outlook e-mail client.

Next step...

◆ Configure Microsoft Outlook
See “Configuring ViewMail for Microsoft Messaging” on page 36.
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Configuring ViewMail for Microsoft Messaging
Configure ViewMail for Microsoft Messaging based on the version of 
Outlook installed on the workstation.

● For Outlook XP or Outlook 2003, see “To configure ViewMail for 
Microsoft Messaging for older versions of Outlook” below.

● For supported versions of Outlook prior to Outlook XP, see see “To 
configure ViewMail for Microsoft Messaging for older versions of 
Outlook” on page 37.

● For Outlook 2007 running under Windows XP, See “To configure 
ViewMail for Microsoft Messaging with Outlook 2007 and Windows 
2000 or Windows XP” on page 37.

● For Outlook 2007 running under the Windows Vista 32-bit operating 
system, see “To configure ViewMail for Microsoft Messaging with 
Outlook 2007 and Windows Vista (32-bit)” on page 38.

To configure ViewMail for Microsoft Messaging with 
Outlook XP or 2003

1 Log on to the workstation as the ViewMail for Microsoft Messaging 
user.

2 Start Outlook.

3 In Outlook, click Tools > E-mail Accounts > Add a new 
e-mail account.

4 Choose  Additional Server Types, then click Next.

5 On the E-mail Accounts page, click ViewMail for Microsoft 
Messaging, then click Next.

The ViewMail for Microsoft Messaging dialog box appears.

6 On the ViewMail for Microsoft Messaging  dialog box, type the 
Server Name or IP address of the  unified messaging server, and 
ensure that TCP/IP is selected as the Protocol.

7 Click the Identification tab and type the Personal ID and the 
Security code assigned to you by the system administrator. Click 
OK.

8 A confirmation dialog box appears, saying that the service will not 
start until you restart Outlook. Click OK to close the dialog box.

9 Exit and restart Outlook.
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To configure ViewMail for Microsoft Messaging for 
older versions of Outlook

1 Log on to the workstation as the ViewMail for Microsoft Messaging 
user.

2 On the desktop, right-click the Outlook icon, then click Properties.

3 Click the Services tab.

4 Click Add.

5 Click ViewMail for Microsoft Messaging.

6 Follow the instructions on the screen to complete the process.

7 Restart the computer.

To configure ViewMail for Microsoft Messaging with  
Outlook 2007 and Windows 2000 or Windows XP

Use the following procedure to configure ViewMail for Microsoft 
Messaging when the e-mail client is Outlook 2007, but the operating 
system is Windows XP.

1  From the taskbar, click Start > Control Panel.

2 Click Mail.

3 Click E-mail Accounts.

 The Mail Setup - Outlook dialog box appears.

4 On the Mail Setup - Outlook dialog box, click E-mail Accounts. 

The Add New E-mail Account page appears.

5 On the Add New E-mail Account page, choose Other, then select 
ViewMail for Microsoft Messaging. Click Next.

The ViewMail for Microsoft Messaging dialog box appears.

NOTE

Use this procedure only if the user does not have 
administrative rights for the workstation, or if the installed 
version of Outlook is older than Outlook XP or 2003.

NOTE

You must perform these steps before starting Outlook 
2007.
 Installing ViewMail for Microsoft Messaging 37



6 On the ViewMail for Microsoft Messaging  dialog box, type the 
Server Name or IP address of the  unified messaging server, and 
ensure that TCP/IP is selected as the Protocol.

7 Click the Identification tab and type the Personal ID and the 
Security code assigned to you by the system administrator. Click 
OK.

8 A confirmation dialog box appears, saying that the service will not 
start until you restart Outlook. Click OK to close the dialog box.

9 On the setup complete page, click Finish.

10 On the Account Settings page, click Close.

11 On the Mail Setup - Outlook dialog box, click Close.

12 Exit the Control Panel, then exit and restart Outlook.

To configure ViewMail for Microsoft Messaging with 
Outlook 2007 and Windows Vista (32-bit)

1 From the taskbar, click Start > Control Panel.

2 Click Mail.

3 On the Mail Setup - Outlook dialog box, click E-mail Accounts.

4 On the E-mail tab, click New.

5 On the Add New E-mail Account page, choose the Other option, 
then in the list select ViewMail for Microsoft Messaging. Click 
Next.

The ViewMail for Microsoft Messaging dialog box appears.

6 On the ViewMail for Microsoft Messaging dialog box, type the 
Server Name or IP address of the unified messaging server.

7 Click the Identification tab and type the Personal ID and the 
Security code assigned to you by the system administrator. Click 
OK.

8 A confirmation dialog box appears, saying that the service will not 
start until you restart Outlook. Click OK to close the dialog box.

NOTES

You must perform these steps before starting Outlook 
2007.
Only ViewMail for Microsoft Messaging 3.4.6 and 
higher support Microsoft Vista (32 bit) and Outlook 
2007.
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9 On the setup complete page, click Finish.

10 On the Account Settings page, click Close.

11 On the Mail Setup - Outlook dialog box, click Close.

12 Exit the Control Panel.

13 Exit and restart Outlook. 
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Upgrading ViewMail for Microsoft Messaging
Upgrade from a previous version of Viewmail for Microsoft Messaging by 
first removing any older version of the application.

In advance of performing this procedure, make sure you have access to 
the network share where the product-specific .exe files are located. See 
“Installation file names” on page 34 for the list of manufacturer-specific 
.exe files.

To upgrade from an earlier version of ViewMail for 
Microsoft Messaging

1 Verify that you are logged on as a system administrator. If not, log off 
the workstation and log on as a system administrator.

2 Close all open programs.

3 Use the steps below to uninstall ViewMail for Microsoft Messaging:

a Go to Start > Settings > Control Panel.

b Double-click Add/Remove Programs.

c Select ViewMail for Microsoft from the list and click 
Remove. 

d Follow the on-screen instructions to complete the uninstall 
process.

4 Copy the VMM_3.4.6.9.exe file to a local drive or the workstation 
desktop.

5 Close all open programs.

6 Double-click the VMM_3.4.6.9.exe file. The ViewMail installation 
wizard starts.

7 Follow the on-screen prompts to complete the installation.

8 When the installation is complete, restart the workstation.

9 Configure Outlook e-mail client. See “Configuring ViewMail for 
Microsoft Messaging” on page 36 for the configuration steps.
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Setting up 
ViewMail for 
GroupWise

If you are installing ViewMail for GroupWise, additional configuration 
steps are required.

1 Install the GroupWise client.
Confirm that the GroupWise 6.0 Windows client with SP4 or 
GroupWise 6.5 Windows client with SP1 is installed on the 
workstations and configured to connect to the local GroupWise 
server.

2 Install ViewMail for GroupWise.
Install ViewMail for GroupWise on the workstations. See “Installing 
the Visual Messaging applications” on page 14.

3 Configure ViewMail for GroupWise.
See “To configure ViewMail for GroupWise” on page 41.

To configure ViewMail for GroupWise

1 Log on to the workstation as a user with administrator privileges.

2 Start the GroupWise client.

3 On the ViewMail for GroupWise login dialog box, type information in 
the following fields:

User ID. The unified messaging personal ID for the user using this 
workstation.

Security Code. The unified messaging security code of the user 
using this workstation.

Voice mail server. The IP address or DNS name of the messaging 
server.

4 Click Login. 

The GroupWise mailbox appears, containing the user’s voice 
messages.

5 Quit all programs and restart the computer.

NOTE

If you want to uninstall ViewMail for GroupWise, see 
“To uninstall ViewMail for GroupWise version 3.1 or later” 
on page 46.

NOTE

Once this procedure is complete, the user does not 
need administrative privileges to use ViewMail for 
GroupWise.
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Using Visual 
Messaging with 
WANs and the 
Internet

In addition to running over a LAN, the Visual Messaging applications can 
run remotely over a wide area network (WAN) or the Internet.

For the remote workstation to establish a TCP/IP connection with the 
unified messaging system, the following two conditions must be met:

● The remote workstation must be connected to the  unified 
messaging system through a WAN, dial-up Internet service, or 
dedicated Internet connection.

● The network administrator must configure the network to enable 
remote connections.

If these conditions are met, the Visual Messaging applications on the 
remote workstation can access the unified messaging system.

To connect remotely to the unified messaging 
system

1 From the remote workstation, connect to the WAN or ISP using 
TCP⁄IP.

2 After the connection between the workstation and host is 
established, start the Visual Messaging application.

NOTE

Network performance can affect Visual Messaging 
performance. Using Visual Messaging remotely can 
significantly affect performance.
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Removing 
Visual 
Messaging 
applications

To completely remove Visual Messaging applications from a workstation, 
determine which version is installed, then use the appropriate 
procedure.

To determine the version of Visual Messaging 
installed

1 On the taskbar, click Start > Settings > Control Panel.

2 Click Add or Remove Programs.

3 On the Currently Installed Applications screen, select the name of 
the Visual Messaging application.

4 Click the Click here for support information link

The version number appears.

5 Find the Visual Messaging application and version number in the 
table below, then follow the appropriate procedure.

To remove… …see

ViewCall Plus version 3.1.x or 
later

“Uninstalling Visual Messaging 
applications from Windows 2000 or 
Windows XP” on page 44.

ViewFax version 3.1x or later “Uninstalling Visual Messaging 
applications from Windows 2000 or 
Windows XP” on page 44.

ViewMail for Microsoft 
Messaging version 3.1.x or 
later

● For Windows XP, see “Uninstalling 
Visual Messaging applications from 
Windows 2000 or Windows XP” on 
page 44.

● For Windows Vista, see 
“Uninstalling ViewMail for Microsoft 
Messaging from Windows Vista” on 
page 45.

ViewMail for GroupWise “Uninstalling ViewMail for GroupWise” 
on page 46.

ViewMail for Lotus Notes “Uninstalling ViewMail for Lotus Notes” 
on page 46.

Mailbox Manager “Uninstalling Mailbox Manager” on 
page 47.
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Uninstalling Visual Messaging applications 
from Windows 2000 or Windows XP
Follow the procedure below to uninstall any of the Visual Messaging 
applications from a workstation running Windows 2000 or Windows XP.

To uninstall Visual Messaging applications, version 
3.1.x or later

1 Close all open applications on the workstation.

2 If you are using Windows 2000/XP and logged on as a user with 
administrative privileges, go to step 3.

Otherwise, log off and log on as a user with administrative privileges.

3 From the taskbar, click Start > Settings > Control Panel.

4 Click Add or Remove Programs.

5 On the Currently Installed Applications screen, click one of the 
following Visual Messaging applications to remove:

■ ViewCall Plus

■ ViewFax

■ ViewMail

■ ViewMail for Microsoft Messaging

6 Click Remove.

7 Follow the on-screen instructions.

8 When the uninstall process is complete, restart the computer.

9 Repeat steps step 1 through  8 for each application you want to 
remove.
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Uninstalling ViewMail for Microsoft Messaging 
from Windows Vista 
Follow the procedure below to uninstall ViewMail for Microsoft 
Messaging from a workstation running any version of the Windows Vista 
operating system.

To uninstall ViewMail for Microsoft Messaging from 
Windows Vista

1 Click Start > Control Panel.

2 Under Programs, click Uninstall a Program.

3 In the list of programs, click ViewMail for Microsoft Messaging, 
then click Uninstall.

If User Account Control has been enabled on the computer, a dialog 
box will appear prompting you to confirm the deletion. Click 
Continue. 

4 Exit the Control Panel.
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Uninstalling ViewMail for GroupWise
Follow the procedure below to uninstall ViewMail for GroupWise from a 
workstation running Windows 2000 or Windows XP.

To uninstall ViewMail for GroupWise version 3.1 or 
later

1 Close all open applications on the workstation.

2 If you are using Windows 2000/XP and logged on as a user with 
administrative privileges, go to step 3.

Otherwise, log off and log on as a user with administrative privileges.

3 On the taskbar, click Start > Settings > Control Panel.

4 Click Add or Remove Programs.

5 On the Currently Installed Applications screen, click ViewMail for 
GroupWise.

6 Click Remove.

7 Follow the on-screen instructions.

8 When the uninstall process is complete, restart the computer.

Uninstalling ViewMail for Lotus Notes
Follow the procedure below to uninstall ViewMail for Lotus Notes from a 
workstation running Windows XP.

To uninstall ViewMail for Lotus Notes

1 Log on to Lotus Notes.

2 Click File > Database > Properties.

3 On the Design tab, select the Inherit design from template 
check box. 

4 Change the template name to Mail (R5.0) or  Mail (R6) or 
Mail (R7).

5 Click File > Database > Replace design to update the e-mail 
database.

6 On the Replace Database Design screen, select Mail (R5.0) or Mail 
(R6), then click Replace.

7 Click Yes to confirm.

8 From the taskbar, click Start > Settings > Control Panel.
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9 On the Control Panel, double-click Add or Remove Programs.

10 On the Currently Installed Applications screen, click ViewMail for 
Lotus Notes, then click Remove.

11 Click Yes to confirm that you want to remove the program.

ViewMail for Lotus Notes will be removed.

12 Close Add or Remove Programs.

13 Close the Control Panel.

Uninstalling Mailbox Manager
Follow the procedure below to uninstall Mailbox Manager from a 
workstation running Windows 2000 or Windows XP

To uninstall Mailbox Manager

1 Close all open applications on the workstation.

2 If you are using Windows 2000/XP and logged on as a user with 
administrative privileges, go to step 3.

Otherwise, log off and log on as a user with administrative privileges.

3 On the taskbar, click Start > Settings > Control Panel.

4 Double-click Add or Remove Programs.

5 On the Currently Installed Applications screen, click  Mailbox 
Manager.

6 Click Remove.

7 Follow the on-screen instructions.

8 When the uninstall process is complete, restart the computer.
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